1. Wir heißen Dich herzlich willkommen in unserer QNAP-Community!
    Information ausblenden

TS-1635 Performance

Dieses Thema im Forum "NAS - Gehäuse" wurde erstellt von HaugeO, 9. Dezember 2016.

Schlagworte:
  1. HaugeO

    HaugeO Neues Mitglied

    Beiträge:
    3
    Punkte für Erfolge:
    2
    Bewertungen:
    +0 / 0 / -0
    Hallo Zusammen,

    wir haben letzte Woche das brandneue TS-1635 bekommen und wie folgt ausgerüstet:
    16 GB HSP
    2 x 512 Samsung EVO SSD als Cache
    5 x Seagate Red 3 TB im RAID5
    => Lese und Schreibperformance Faktor 10 x langsamer als bei unserem alten TS-669L mit 4 GB HSP ohne SSD-Cache mit 6 x 3 TB WD im RAID6.

    Die IOPS beim alten liegen z.B. beim Kopieren von einer externen USB-HD auf das RAID6 mit 1.800 im Vergleich zum neuen NAS mit max. 250 IOPS um Lichtjahre auseinander. Auch beim Zugriff über das Netzwerk ein identisches Verhalten.

    Woran kann das liegen (SSD-Chache ein-/ausschalten, zwei weitere RAIDs einmal RAID1 und auch RAID0 haben auch nichts gebracht). Ich hatte mal bei einem Dell-Server ein ähnliches Verhalten , dort musste erst im BIOS der Schreib-Cache auf dem Festplattenkontrolle (über SSH-Zugriff aktiviert) werden, gibt es sowas beim QNAP auch?

    Ich bin echt verzweifelt, der QNAP-Support (Helpdesk) lässt seit einer Woche auch auf sich warten...

    Vielen Dank für Eure Unterstützung
    Oliver Hauge
     
    Zuletzt bearbeitet: 9. Dezember 2016
  2. Bladekiller

    Bladekiller QCD e.V. Mitarbeiter Administrator

    Beiträge:
    875
    Punkte für Erfolge:
    29
    Bewertungen:
    +95 / 20 / -0
    Hallo Oliver,

    nun das ist ein unnormalesVerhalten, dies kann meiner Meinung nach mehreren auslösende Faktoren haben.
    • den Cache sollte man einstellen können ob er genutzt wird oder nicht, mir ist aber die Stelle gerade nicht bekannt, da ich keine vergleichbare Maschine hier zuhause habe (siehe unten)
    • inkompatible Festplatten ( ich kenne keine Seagate RED sondern nur WD Red Platten) hier würde ich gerne mal die originalfesten Plattenbezeichnung sehen.
    • möglicherweise befindet sich das RAID5 noch im aufbauen und bremst so das gesamte System aus
    • eine defekte Platte im System - bitte die Smartwerte checken
    • Defekt der Netzwerkschnittstelle am NAS
    • Defekt am Switch
    • Switch fehlerhaft eingestellt (100Mbit statt 1Gbit)
    • gleiches gilt für den direkten Anschluss an eine FRITZ!Box
    • defektes Netzwerkkabel oder Anschlussdosen
    • und natürlich nicht auszuschließen ein Defekt des Gerätes selbst.
    alle Einstellungen am NAS und somit auch am Cache werden in der Verwaltungs Oberfläche gemacht - wo allerdings ist mir leider gerade nicht bekannt. Letztendlich sollten sie aber im Speichermanager zu finden sein.

    Ich hoffe diese Information bringen dich ein wenig weiter

    Grüße
     
  3. Bladekiller

    Bladekiller QCD e.V. Mitarbeiter Administrator

    Beiträge:
    875
    Punkte für Erfolge:
    29
    Bewertungen:
    +95 / 20 / -0
    Habe gelogen :D

    hier die Stelle der Einstellungen
    Cachebeschleunigung.jpg
     
  4. HaugeO

    HaugeO Neues Mitglied

    Beiträge:
    3
    Punkte für Erfolge:
    2
    Bewertungen:
    +0 / 0 / -0
    Hallo Bladekiller,
    vielen Dank für Deine Antworten. Mittlerweile bin ich etwas weiter da auch den QNAP-Support sich endlich gemeldet => nach dem Aufspielen einer aktualisierten Firmware, welche übrigens nicht über die Echtzeitüberprüfung innerhalb der Firmwareüberprüfung gefunden sondern manuell heruntergeladen und installiert werden muss, erreiche ich endlich dieselbe Schreibgeschwindigkeit wie auf unserem alten NAS (105 MB/Sek beim Kopieren von einer externen USB-Platte auf das interne RAID5). Allerdings nur solange wie der SSD-Cache ausgeschaltet ist. Mit eingeschaltetem Cache bricht die Schreibperformance nach einiger Zeit auf die Hälfte ein. Mir scheint QNAP muss hier noch ein wenig nacharbeiten, von den in den QNAP-Beschreibungen angegebenen Performancewerten sind wir noch weit entfernt...

    Melde mich sobald es weitere Neuigkeiten gibt
    Oli
     
  5. Bladekiller

    Bladekiller QCD e.V. Mitarbeiter Administrator

    Beiträge:
    875
    Punkte für Erfolge:
    29
    Bewertungen:
    +95 / 20 / -0
    Moin,
    danke für die Rückmeldung. Ich habe mich vorhin mit unserem Challenger ein wenig über dieses Thema viaTeamspeak unterhalten. Wir haben uns hierzu noch einmal die Spezifikationen und das Vorgehensmodell des SSD-Caches von QNAP angeschaut. Hierzu können wir dir folgenden Link zu einem Tutorial anbieten.
    Hierzu einige Gedanken von uns zu diesem Thema, mit der Du dieses Tutorial einmal betrachten müsstest:
    • sofern Du Dich nach dem aufsetzen des NAS noch in der Befüllungsphase befindest, macht es bei der Speichercharakteristik einer SSD Sinn für die Zeit des Befüllens den SSD-Schreib-Cache abzuschalten.
    • Für den Lesecache scheint es irrelevant zu sein.
    • Der SSD Cache macht vorrangig dann Sinn, wenn es sich um häufige von mehreren Nutzern durchgeführten und wiederkehrende Schreib.- oder Lesezugriffe auf bestimmte Dateien handelt. Passt dein Nutzerprofil beim befüllen dazu?
    • gerade beim Befüllen eines Systems würde er bei gesetztem Schreibcache alle Daten immer über die SSD ziehen, was diese zum einen stark belastet und zum anderen bei großen Datenmengen die SSD in die Knie zwingt. (die Schreibgeschwindigkeit von SSD nimmt in dem Moment ab, ein Speicher Zellen bereits Werte enthalten.)
    • so wie ich denn SSD Cache verstanden habe lernt er sich auch anhand der Zugriffe auch erst an indem er die Daten in Hot- und Cold-Data einteilt und diese jeweils bei Hot auch im SSD Cache bereitstellt.

    Welche Datenzugriffe habt ihr nachher im produktiven Betrieb mit diesem NAS ?
     
  6. HaugeO

    HaugeO Neues Mitglied

    Beiträge:
    3
    Punkte für Erfolge:
    2
    Bewertungen:
    +0 / 0 / -0
    Nabend,

    erst einmal Dankeschön für Eure Unterstützung!

    Also der SSD-Cache ist zur Zeit für alle RAID-Volumes deaktiviert und das NAS wird tatsächlich erst einmal weiter befüllt. Der produktive Einsatz der QNAP-NAS (TS-1635 und TS-669L) sieht nachher wie folgt aus:
    Je ein ESX mit mindestens einem internen RAID10 für die Betriebssystempartitionen der VMs sowie Datenpartitionen für SQL-Server mit höherem IO-Durchsatz bekommt ein QNAP-NAS zugeordnet für die weniger IO-intensive Datenbanken oder seltener benutzte Kundendatenbanken sowie der allgemeine Dateiablage, Archiv zugeordnet. Die Sicherung der VMs erfolgt jeweils mit Veeam auf das nicht zugeordnete QNAP-NAS (also kreuzweise). Dabei werden täglich je ESX ca. 2 TB Daten gelesen und bis zu 500 GB geschrieben, d.h. im Tagesverlauf eher zufällige I/O durch die ESX (insgesamt 3, 2 x produktiv, 1 x Entwicklung), nachts und am Wochenende sequentielles Lesen und Schreiben im Rahmen der Datensicherung/Vollbackup.

    Die Ausführungen zum SSD-Cache kann ich teilweise nachvollziehen, bin aber dennoch der Meinung, dass das neue TS-1635 mit 15-fachen Hauptspeicher und 2 x 512 SSD-HDs (als Cache) einen wesentlich höheren und konstanteren Durchsatz als das drei jahre alte TS-669 bringen muss. Die zur Zeit im Netz erreichte Übertragungsrate bleibt noch weit unterm dem Maximum von 1 GBit, d.h. noch nicht einmal einer de beiden gebündelten Netzwerkkarten wird ausgelastet. Bei positiven Tests war zusätzlich geplant mit den 10GBit-Anschlüssen einen entsprechend performanten Backbone aufzubauen.

    Auch wenn man das TS-1635 (in unserer Ausstattung hat es auch knapp 2.500 € brutto gekostet) nicht mit einem echten SAN (10-20K bei Kunden) vergleichen kann, etwas mehr hätte ich jetzt doch erwartet. Das es zur Zeit bei allen Performancetests hinter dem alten TS-669 zurückliegt kann aber doch nicht sein, oder?

    Also warte ich mal die vollständige Befüllung ab, schalte dann den SSD-Cache an und mache noch ein paar Tests. Außerdem handelt es sich um eine ganz neues Produkt und in Sachen Firmware/Support scheint sich ja auch hoffentlich noch etwas zu tun.

    Bin natürlich weiterhin für jeden Hinweis (auch bei grundsätzlichen Fehlern in der Konzeption) dankbar!

    Gute Nacht und beste Grüße
    Oli
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden