1. Wir heißen Dich herzlich willkommen in unserer QNAP-Community!
    Information ausblenden

Webkonnektivität bei my QNAPcloud zeigt Fehler

Dieses Thema im Forum "Troubleshooting (Einsteiger)" wurde erstellt von simone, 26. Februar 2020.

  1. simone

    simone Neues Mitglied

    Beiträge:
    3
    Punkte für Erfolge:
    2
    Bewertungen:
    +0 / 0 / -0
    Hallo QNAP Community Forum,

    ich möchte WebDAV verwenden um von PC und MAC aus direkt auf die Daten der NAS zugreifen zu können.
    Das ganze soll auch von einem anderen Standort aus möglich sein.

    Via SmartURL https://qlink.to/xxx kann ich mich auf der QNAP anmelden.
    Via Internetadresse https://xxx.myqnapcloud.com jedoch nicht. Das ist jedoch vermutlich eine Voraussetzung, richtig?

    myQNAPcloud DDNS-Dienst ist aktiviert

    FritzBox 7490 Firmware 07.12
    QNAP TS-210 Firmware 4.2.6 build 20200109

    Selbstständige Portfreigabe ist aktiviert. Freigegebene Ports: 8080, 64008, 80, 8081

    Weshalb ist der Port 64008 automatisch freigegeben, wenn doch bei der automatischen Router-Konfiguration für "Sichere NAS Web" 8082 steht, so wie es auch bei Systemadministration konfiguriert ist?

    Ich bedanke mich schon jetzt für eure Hilfe
     

    Anhänge:

  2. Bladekiller

    Bladekiller QCD e.V. Mitarbeiter Administrator

    Beiträge:
    841
    Punkte für Erfolge:
    29
    Bewertungen:
    +93 / 20 / -0
    Hi,... und ein herzliches Willkommen hier in der Community,

    Schalte mal den Rebindschutz deiner Fritzbox temporär aus und teste dies,...
     
  3. simone

    simone Neues Mitglied

    Beiträge:
    3
    Punkte für Erfolge:
    2
    Bewertungen:
    +0 / 0 / -0
    Danke für die Antwort.

    Obwohl ich wissentlich nichts mehr geändert habe, ist bei einem erneuten Test heute ein grüner Haken hinter Webkonnektivität. Mir soll's recht sein.
    Vermutlich liegt es daran, dass jetzt über die Selbstständigen Portfreigabe die Ports 8080, 8082, 80, 8081 freigegeben sind, also anstelle des 64008 der 8082, so wie auch in der NAS konfiguriert. Ich hatte die FB zwischenzeitlich mal neu gestartet, evtl. hat das die Änderung gebracht.

    Beim Aufrufen der Seite xxx.myqnapcloud.com kommt diese Meldung.

    FRITZ!Box
    Der DNS-Rebind-Schutz Ihrer FRITZ!Box hat Ihre Anfrage aus Sicherheitsgründen abgewiesen.
    Der Host-Header Ihrer Anfrage stimmt nicht mit dem Namen der FRITZ!Box überein.
    Wenn Sie über einen anderen Hostnamen auf die FRITZ!Box zugreifen wollen, ergänzen Sie diesen bitte als Ausnahme in der Benutzeroberfläche Ihrer FRITZ!Box unter "Heimnetz > Netzwerk > Netzwerkeinstellungen" im Bereich "DNS-Rebind-Schutz".

    Nach der Eintragung von xxx.myqnapcloud.com als DNS-Rebind-Schutz Hostnamen Ausnahme, komme ich über die xxx.myqnapcloud.com (von extern) auf die Anmeldeseite der Fritzbox.
    Gebe ich den Port :8080 mit an, komme ich auf die NAS. -> super
    Es erfolgt eine Weiterleitung an den sicheren Port für HTTPS (in meinem Fall) :8082 -> das ist natürlich gut und richtig so.
    Allerdings wird mir "Nicht sicher" angezeigt, weil kein Zertifikat installiert ist.
    Ich würde gerne ein Zertifikat von letsencrypt.org verwenden, so wie bei dieser Anleitung beschrieben. https://gadgetchecks.de/qnap-qts-4-3-tutorial-verbindung-absichern-mit-einem-ssl-zertifikat/
    Warum fehlt bei meiner NAS die Möglichkeit ein Let's Encrypt Zertifikat zu verwenden?
    Unter Systemeinstellungen -> Sicherheit -> Zertifikat & privater Schlüssel ist es auch nicht möglich ein Zertifikat von Let's Encrypt zu beziehen. Bei dem NAS eines Bekannten ist das möglich, siehe Screenshots.

    Noch eine Frage: Ist es ein Sicherheitsrisiko wenn ich xxx.myqnapcloud.com als DNS-Rebind-Schutz Hostnamen Ausnahme eingetragen habe?
     

    Anhänge:

    Zuletzt bearbeitet: 27. Februar 2020
  4. simone

    simone Neues Mitglied

    Beiträge:
    3
    Punkte für Erfolge:
    2
    Bewertungen:
    +0 / 0 / -0
    Halli Hallo, kann mir hier keiner meine Fragen beantworten? :Fahne:
     
  5. Bladekiller

    Bladekiller QCD e.V. Mitarbeiter Administrator

    Beiträge:
    841
    Punkte für Erfolge:
    29
    Bewertungen:
    +93 / 20 / -0
    Sorry,... bin hier grad etwas out of Order.

    Nun, es schein das die Firmware 4.2.6 diese Funktion nicht unterstüzt. Diese funktion kam esrt mit der 4.3.x dazu. Für Dein NAS x10 fehlt diese Software aber, da von QNAP als EOL gekenzeichnet. :-(

    Nein, da Du ja die Quelle der Herkunft kennst. und dies selber so " wolltest "

    Übrigens ist ein eigenes, selbst signiertes Zertifikat auch nicht unsicher,.... es seih denn Du vertraust dir selber nicht :)einem fremden selbst zertifiziertem Zertifikat würde ich aber auch nicht vertauen.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden